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1. Introduction

Aloaha PDF Saver offers a reasonable solution to save data from PDF forms.

You can write and save data in your PDF forms. You do not need a full version of Adobe Acrobat
and save the royalties for Adobe Acrobat full versions.

With Aloaha PDF Saver you are able to: 
· Save data from PDF forms and open them later again 
· Save data as a complete PDF file
· Save data as a complete PDF file with deleted fields. Only the data is written in the form.

Thus an e-mail receiver cannot modificate the PDF form. 
· Paste Text fields or change the properties and position of existing text fields. 
· Place Pictures on your document. 
· Use the Aloaha PDF form Saver as an alternative PDF reader, because no Adobe Reader

is necessary. 
· Print PDF files which cannot be printed by other readers. 
· package contains Form Saver OCX.



5Introduction

© 2010 Wrocklage Intermedia GmbH

2. Usage
You open any PDF document to fill the form with the Aloaha PDF Saver.

Note: You can open a Toolbar via View > Toolbar or CTRL-T !

To save a file and overwrite an old one you can click with the help of the toolbar on the disk icon.
The system asks you if you want to overwrite the existing file.
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If you liked to save only the form data as a XML file go forward as shown below:

Click on File > Save as ...

... and save the form data as file type xml.

Note: If you open this XML file with Aloaha the program automatically opens the
corresponding PDF and enters the XML data!



7Usage

© 2010 Wrocklage Intermedia GmbH

3. Installation

System requirements
Installation
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3.1 System requirements

· Windows 2000, Windows 2003, Windows 2008, Windows XP, Windows Vista, Windows 7
· No Adobe Reader necessary! 
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3.2 Installation

To install the Aloaha PDF Saver please download the installation package from 
http://www.aloaha.com/download/aloaha_saver.zip

The installation package contains a file 'aloaha_saver.exe'. Please start that file with a double
click.
After you choose your language the setup will start.

http://www.aloaha.com/download/aloaha_saver.zip


10 Aloaha PDF Saver

© 2010 Wrocklage Intermedia GmbH

Setup will ask you for the installation folder before it begins to install the product. 
For using a different folder, click the Browse button and select the folder you want to install to.

Note: It is suggested to install all Aloaha products in the same directory.

If setup has installed successful the application you have to click the finish button.
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4. Configuration

Page
Info
Help
File
View
Print
Settings
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4.1 File

To be able to open or to save PDF documents select in the menu bar file>...

Alternatively you can "open, sign or save" documents about the Toolbar (CTRL + T).
If you work with the toolbar, you will have advanced memory options.
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4.1.1 Open

Should you open an encrypted document with a digital ID, it is necessary, that your digital ID is
correctly installed. 
If necessary contact the author of the document.

If there is no digital ID available, the document cannot be opened.

4.1.2 Save / Save as

If you liked to save a signed PDF file, select "Save" or "save as".
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4.1.3 Upload to

If you liked to upload documents on a WebDAV server (as for example Microsoft Exchange or
SharePoint server), select the command "Upload to".

After you have entered the filename of the file to be uploaded, you are requested,

to enter the username and the matching password, so that the file can be uploaded.
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4.1.4 Save read only

With the option "Save read only", it is not possible to change document afterwards.

After the storage process it is not possible any more to change dropdown fields.
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4.1.5 Sign 'n' Save

With the command "sign 'n' save" the document is sealed and saved as a PDF document.

Before saving you where asked to select a file store and to stock the document with a filename.
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4.1.6 Exit

With the command "Exit" the application is closed. 
Before you should have saved the documents.
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4.2 View

In the menu "View" following options stand at possession:

· Mode
· DPI
· Best Size
· Toolbar

4.2.1 Mode

In the menu View > Mode can be selected between the Aloaha or the Adobe mode.

In the Adobe mode the standard application Adobe Reader is used to display your PDF files.

In the Aloaha mode there is NO Adobe PDF reader! PDF reader software is not able to save the
form data. 
This means if you close the Adobe PDF reader, all in the PDF form entered data get lost. 
The Aloaha PDF-Saver allows you to save the PDF document includes the entered data.
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4.2.2 DPI

DPI is synonymous with “dots per inch”. In the general usage the resolution of a printing file is
meant. 
In the printing process the print format is converted into small dots, is printed in halftone so. This
halftoning is hardly visible to the viewer.

The resolution can be adjusted accordingly of the desired print format in the menu View > DPI.

With rising number the quality of the representation - and also the data volume increases.

Today customary laser and inkjet printers reach approx. 300 dpi, higher valued laser printer about
600 dpi. 
Only printers and beamer with resolution of more than 1000 dpi are enough for professional
claims.

The quality of scanners moves in the same ranges like printers.

The resolution of monitors mostly lies at 72 dpi.

As an appoximate value you take:

72 dpi for graphics in the Internet,
90 dpi for film and
300 dpi for the pictures which you would like to print out.
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4.2.3 Best Size

In the mode "best size" fits Aloaha the screen window optimally to the available system resources.

4.2.4 Toolbar

You can call the toolbar, while you

· select the keyboard shortcut CTRL + T
· select View > Toolbar in the menu.

Different settings are able to be adjusted to the following points in the toolbar:

· Documents open, sign and save
· directly save
· print document
· Settings for the digital signature
· sign document electronically and save
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4.3 Print

You have different possibilities to reach to the printing menu.

· Select the menu item "printing" about the object menu

· CTRL + T > Dropdownfield besides the printer

Other dots in the printing menu

· Use Adobe Engine
· Settings
· Print
· Print to default printer
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4.3.1 Use Adobe Engine

With "Use Adobe engine" you inform the program to use the Adobe engine instead of the own
printing engine. In some cases it can be an advantage.

Informations about the Adobe Print Engine 2

Powering the next generation of PDF workflows

Adobe® PDF Print Engine 2 enables integrated, end-to-end PDF workflows for printing graphically
rich content, including variable content for personalized publishing. Adobe OEM partners are
building the technology into the next generation of prepress and print solutions. Adobe PDF Print
Engine 2 streamlines print production by utilizing a single workflow for all job types — offset, short-
run digital, and Variable Data Publishing (VDP) — maximizing reliability and flexibility and providing
new opportunities for growth. It provides printers with an easy on-ramp to add personalized
publishing to their existing workflows.

Adobe PDF Print Engine 2 builds on the proven success of version 1. It combines the strengths of
Adobe PDF for content definition with the power of JDF for workflow automation. Soon to be
available in printing systems from Adobe partners, Adobe Print Engine 2 simplifies upstream VDP
workflows and unifies prepress production. It empowers designers to create leading-edge content
with confidence, knowing it will be reproduced as expected.
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4.3.2 Settings

About the tool bar (CTRL + T) you reach to the printing menu.
Here you select print settings for your document.

austauschen gegen Toolbar!!!!

In the menu item "advanced settings" you can fix which of the available printers in the system
should be used to print out your PDF documents.
Should the printer dispose several possibilities of the paper feed, you can select this in the menu
item "Paper Tray".

If you activate the field "Eco", your document is printed in the toner / ink saving mode.

If you activate the field "Duplex", it is printed at the same time or in two steps of front and back of
the media.

If you select the command "Print", the document is printed on the default printer.

If you select "print to", the document is printed to a printer of your choice.

If you select "print current page", the currently indicated page is printed to the default printer.

If you select "print current page to", the currently indicated page is printed to a printer of your
choice.
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4.3.3 Print

If you select the menu item "print", Aloaha prints all documents to the default printer.
Alternatively you can also fix a printer of your choice for the printouts.

4.3.4 Print to default Printer

If you select the menu item "print to default printer", Aloaha prints all documents to the default
printer.
Alternatively you can also fix a printer of your choice.
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4.4 Settings

In the menu settings you have the possibility to configure settings for:

· Borders
· Digitally Sign
· Language

4.4.1 Borders

If you select Settings > Borders form fields are shown framed.

View without frames:

View with frames:
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4.4.2 Digitally Sign

Digital Signature

A digital signature for the purposes of the law is „a seal generated with a private signature key to
digital data which with the help of an accompanying public key, with a signature key certificate of a
certification authority stock is, the owner of the signature key and the unadulterated quality of the
data reveals“ (SigG.).

With the development of the digital signature the destination was traced to develop one of the
personal signature equivalent signature method with which on electronic way data can be signed.

The main problem by transmission of electronic data is the manipulability. The problem could be
eliminated only by electronic signature, because an unnoticed manipulation of data is no more
possible.

Requirement is that the electronic signature is connected like a handwritten signature inseparably
with the respective document. It can be seen by everybody, but only be changed by the signer
itself. The signer can be identified and the signature makes every possible manipulation, like
additional pranks or changing text passages, immediately recognizable.

By the certificate check can be proved that the signature was not faked and the certificate owner is
real. except his name no personal data is revealed.

Legal regulations

Definitions of different kinds of the digital signature are found in the signature law (SigG) and in the
order to the signature law (SigV). In it demands for the electronic signatures are as well displayed
as Certification Service Provider (ZDA) were defined.

It is distinguished in easy, advanced and certified digital signatures. Every signature stands for a
certain quality level. The higher valued the signature, the more meaning she has for the legal
relations, and the greater is her functionality.
Only certified signatures fulfil the demands concerning electronic data just as the handwritten
signature demands concerning data in paper form. They are admitted in court as an evidence. 

The cryptographic algorithms admitted for certified electronic signatures are approved and
published by the federal network agency. under www.bundesnetzagentur.de you find a list of all
accredited Certification Service Provider (trust centres). There are also listed the products
admitted for a certified electronic signature.

The requirements for a certified signature are given when:

· this can be associated exclusively to the signatory who admits unequivocal identification of the
signatory

· with means is created which only the signatory controls
· makes every additional update of the signed data evident
· is based on a certified certificate

A certified certificate can only be issued by an accredited Certification Service Provider.
Particularly strict demands concerning the security of the key creation and the organisation of the
trust centre are valid. The observance of the legal instructions through the trust centre is in
Germany also controlled by the federal network agency.
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Public Key procedures

Digital signatures are based on asymmetrical Crypto systems and use a key pair which passes
signature key of a private (confidential one) and public (not confidential).

The data which were encoded with one key can be opened again only with the other.

In order to sign the private key is used. The key is on the chip of the card and cannot be read out.
The data to be processed are loaded on the chip, are encrypted or decrypted there and transmitted
again back to the computer. 

To use the private key, the right PIN which guarantees additional security is required. The
signature can be only from the card owner, because only he is in possession of card and PIN.

The public key is integrated into a certificate and is available for everyone. This can also be
retrieved by directory services via LDAP or HTTP. Of course he can also be dispatched by e-mail.

To guarantee that the certificate and therefore the key was not faked, every certificate is signed by
the publisher. Therefore checks up to themselves whether the certificate of a trustworthy place
was published.

While checking the signature the public key of the receiver is used. The encrypted Hash value of
the publisher is decrypted and compared to the Hash value of the document. If both values agree
the document was not modified.

While signing a file a Hash value which is comparable with a fingerprint is formed. Two different
documents can never have the same Hash value. The Hash value is encrypted under use of a key
with a length of at least 1024 bits (depending on the used card) after the procedure RSA .

The encryption of the Hash value takes place on the card with electronic chip processor which can
process smaller data volumes. Thus it is made sure that the private key does not leave the card.
The encoded Hash value is sent back again to the computer and is seated in the document to be
signed. Before the document could be signed the private key must be released by the right PIN
(Personal Identification Number).
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4.4.3 Language

Should you need another Userlanguage than the currently used, you can move this here.
After occurred conversion the program requires a restart, so that the updates become effective.

Currently available languages:
· German
· English
· Italian
· Dutch
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4.5 Page

Should your PDF document exist of several pages, you have the possibility with 

· F12-Key > to scroll one page forward
· F11-Key > to scroll one page backward
· CTRL + E > to jump at the end of the document

4.6 Info

In the info area you find information about licensing.

In this document you see in the system found licence informations.
You can save own licences, while you enter a valid key file and confirm the operation.
You get licences of Aloaha software from us by e-mail.

4.7 Help

You reach the Online Help about the F1 key or the Online Forum about the keys CTRL + F1.
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5. Language.ini

Aloaha Translation/Localisation Engine
Recent Builds of Aloaha localise/translate used strings fully automatic. String Tables are saved as
ini files to allow the user to change strings himself or to localise into a new language without having
to touch the Aloaha Code.

Translation Mechanism
· When Aloaha starts it looks for the language settings in language.ini. If that file does not exists

Aloaha will ask
          o HKCU\Software\Aloaha\language
          o HKLM\Software\Aloaha\language
          o The Operating System LanguageID

· Based on the LanguageID Aloaha will ask UserLanguage_<ID>.ini for the string

translation. If that file does not contain the correct translation Aloaha will ask 
Language_<ID>.ini

· The file Language_<ID>.ini will be overwritten by every setup/upgrade. In case a user

wants to modify strings it is suggested to use UserLanguage_<ID>.ini

 

Language.ini
Section [Mapping] instructs to map one language to another. For example 410=409 would mean to
use english (409) on italian (410) systems

Section [languageID] defines which ini files to use for the current mapping.

Translation Files
First Aloaha will ask UserLanguage_<ID> for the translation. If no translation is found it will

ask Language_<ID> for the translation.

If a user wants to change strings it is advised to do the changes in UserLanguage_<ID>.
ini since Language_<ID>.ini will be overwritten with every setup/upgrade.

It is also possible to set registry key HKLM\Software\Aloaha\pdf\WriteMissing
to 1. In that case Aloaha will log all Translation Problems to MissedLanguage_<ID>.ini.

This is very usefull to find the strings to be translated for the new language/localisation.
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6. Tips and Tricks

Aloaha PDF Saver Tips and Tricks

Seal a  PDF Form
Sometimes you need to make sure that you filled PDF Form cannot be edited anymore. To seal/
flatten such a form just right click on the PDF and choose Flatten from the menu. Aloaha will now
remove all formfields from the PDF and re-render the formfield contents to the PDF.

Digitally Sign a PDF Form
Aloaha is able to apply a digital signature to any PDF Document or PDF Form. It is not required
that the PDF has a special signature field. To sign the PDF just just draw a bounding box with to
mouse clicks. As soon you right click into that bounding box you can choose to sign the document
from the menu. Aloaha will now flatten the PDF and apply the signature.

Annotate your PDF Document
It is possible to draw a bounding box with to mouse clicks on the intended position and then right
click into this box. You can choose from the menu "Add Text Box". This function adds a Text Form
Field to the PDF Document. If you disable printable this Text Form Field can act as a note box.

Edit Form Field Properties
Just double click on a formfield to change the formfield properties. Like this its possible to change
position, size, font etc of the selected form field.

Loading/saving documents to/from a sharepoint library
Aloaha supports loading and saving directly to/from sharepoint. To load a document from
sharepoint just type in the URL into the file open dialog. 

To be able to save a loaded file directly back to the sharepoint library it is required to start the PDF
Saver with a command line argument. The reason is that if a URL is typed in into a windows open/
save dialog windows will remap that URL to a local file in the temp directory.

For example if you load a file with the commandline: PDFSaver http://yourserver.
tld/pdfdocument.pdf you are able to save it back to the library with just pressing the

save button.
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7. FAQ

What for can I use the Aloaha PDF Saver?

In the freely available Adobe Reader you can fill PDF forms, but do not save. The Aloaha PDF
Saver offers this function.

I get a response after I have filled a form: You cannot save the entered data.

The Aloaha PDF Saver uses the standard configured PDF reader to display PDF documents. This
message can be ignored, because Aloaha saves the form! It is better to changed into the native
Aloaha mode. 
Use this way: Menue > View > Mode

If I fill a form and save, weird characters appear

Your PDF form is probably encrypted. The demo version of the Aloaha PDF Saver supports no
encrypted forms. The Aloaha form Saver can open in the full version password-protected and
encrypted files. Please request a test key.

How can I use the Aloaha PDF Saver OCX?

To install the Aloaha PDF Saver please download the installation package from 
http://www.aloaha.com/download/aloaha_saver.zip. In the subdirectory \sample\formsaver you find
examples to use.

What is the difference between Aloaha and Adobe mode?

In the Adobe mode the standard application is used to display your PDF files. This is your Adobe
Reader. The Adobe mode is limited in the functionality. 

You obtain better functionality if you use the Alaoha mode!

What means "Adobe Compatibility mode" in the Adobe mode?

Compatibility problems between Adobe Reader 7 and 8 are compensated. This mode is only
recommended if you have problems!

How can I create a form field?

1. Please check whether HKEY_LOCAL_MACHINE\SOFTWARE\Aloaha\PDFSaver\edit has the
value "1"
2. Make sure that you have set the Aloaha mode in the PDF Saver
3. Draw an input box
4. Click in the box and select Edit -> Add Text Field

What is the difference between Saver and Signator?

The Saver puts forms to the focus on PDF, the Signator puts the focus on digital signatures.

Do not hesitate to contact >>aloaha@wrocklage.de<< in case you do not find your

response. You can also use this forum: http://portal.aloaha.com/saver/default.aspx

http://www.aloaha.com/download/aloaha_saver.zip
http://portal.aloaha.com/saver/default.aspx
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